This project is read-only.

Could not load file or assembly 'AlphaVSS.60.x64

Jul 10, 2012 at 2:48 PM

Hi,

I'm using the lastest version (alphavss-92071) of AlphaVSS with Visual Studio 2010 Ultimate on a Windows 2008 x64 OS.

After succesfully rebuilding the solution and starting the AlphaShadow exe it returns the following error:

lphaShadow v1.2 - AlphaVSS Volume Shadow Copy Library Sample Client
Copyright c Peter Palotas 2008-2012

Final context: 0
Error: Could not load file or assembly 'AlphaVSS.60.x64, Version=1.2.4000.3,
       Culture=neutral, PublicKeyToken=959d3993561034e3' or one of its
       dependencies. The located assembly's manifest definition does not
       match the assembly reference. (Exception from HRESULT: 0x80131040)

Dll's and exe are in the same folder.

Could somebody give me a hint where to go frome here?

- Peter

Oct 8, 2012 at 4:02 PM

Hi Peter,
I've got the same problem on one (out of three) PCs running Windows 7 Pro 64 bit with .NET 4 using AlphaVSS v1.2 Beta 1 (for .NET 4). Despite working fine on two of my systems, I got this error message on the very PC which has a SSD and all partitions are on this SSD. Could that be the reason?

Anyway, I haven't had time yet to test it with the latest AlphaVSS version.

Regards,
fuggi

Jan 21, 2013 at 9:59 PM

Hi guys,

I had the same problem today, and it appears that Visual Studio 2010 runtime was missing from the computer where the problem occurred.

So installing vcredist may fix the error (it worked for me).

Cheers.